iOS 11 Readiness and Xcode 9

We are now a few weeks away from the iOS 11 General Availability(GA) release. During the last few weeks, we have been evaluating the iOS 11 Beta releases and releasing the Kony compatible releases for all the supported versions of Kony Visualizer as part of our OS upgrade program.

 

Many of you have already taken advantage and secured your mobile applications for iOS 11 by testing your existing applications against the iOS 11 compatibility mode or by upgrading to our Kony compatibility releases. In case you have not already done this already, we recommend you to do this at the earliest.   As part of this step, if you take the iOS 11 compatible release, you will need to upgrade to Xcode 9.

 

Here are a few important things you need to know about moving to Xcode 9:

  • With every iOS release, Apple also releases an updated version of its development environment, Xcode. The updated Xcode version provides support for the new iOS features. With iOS 11, Apple has released Xcode 9. We have already ensured that our customer applications are compatible with both iOS 11 and are ready to use Xcode 9.
  • While your application may continue to work with Xcode 8 in an iOS 11 compatibility mode without taking the iOS 11 compatibility release, we recommend you to start using Xcode 9. This will ensure Apple compliance for any future updates.
  • With Xcode 9, Apple has introduced a new framework related to the UI Kit which is an extensively used framework for the UI interface including animations and event handling.  While Kony ensures that our iOS 11 compatibility releases use Xcode 9, the application developers using the Kony iOS 11 compatible releases are expected to ensure that they use Xcode 9 to build their iOS applications.
  • Not using Xcode 9 with the iOS 11 compatibility releases will most likely result in build problems due to non-availability of the new framework in earlier versions of Xcode.
  • Additionally, while you are building your applications with Xcode 9, ensure that any FFIs (including 3rd party) and Custom Widgets used in your applications are compatible with Xcode 9.
  • We know that customers are also very interested in taking advantage of new developer APIs in the new OS release. These new APIs will be available in our upcoming releases and will be compatible with Xcode 9 only.
     

As always, Kony is committed that our apps follow the best practices and stay updated. Stay tuned for the latest announcements and updates on the OS Upgrades on our community portal.

 

If you have any questions about your applications or the upgrades, please don’t hesitate to reach out to Kony Support.