Important! A new Community experience launched on September 26, 2017. Read more about it here or continue to Base Camp.
Voting: 
Vote up!
5 Votes
10 Replies

startup.js-->svcDoc: Uncaught SyntaxError

Sri Harsha Vemu on Feb 01, 2016 10:40 EST

Posted In
Vote up!
4 votes
Vote down!

Same error here.

It started after I uploaded the plugins.

Replied by: Feb 01, 2016 15:10 EST
Vote up!
2 votes
Vote down!

Same here.

Replied by: Feb 02, 2016 04:48 EST
Vote up!
3 votes
Vote down!

Me Too!!

Replied by: Feb 02, 2016 07:21 EST
Bronze
Vote up!
1 votes
Vote down!

Hi Harsha,

We have tested with the same plugins. We are able to build and deploy the app on android devices without any issues.

Can you please restart Studio or change workspace and test with new application. If still any issues then please provide the screenshot of the error and more details to further debug.

Thanks.

Replied by: Feb 02, 2016 08:07 EST
Gold
Vote up!
2 votes
Vote down!

Hello Madhuri,  

   I tried the following

  1. Restarted Kony Studio, changed work space and made a build
  2. Imported another project on a new work space and made a build

Which brings me the same error. Please see screenshot below.  

   

Replied by: Feb 02, 2016 08:39 EST
Vote up!
3 votes
Vote down!

Same here. Even with a new project from the Traning course. Since it is training course I can zip it up for you. If that helps.

I also found the actual problem inside the startup.js file:

 

var appConfig = {
    appId: "MovingWidget",
    appName: "MovingWidget",
    appVersion: "1.0.0",
    platformVersion: null,
    serverIp: "167.20.20.123",
    serverPort: "8080",
    secureServerPort: "443",
    isDebug: true,
    middlewareContext: "middleware",
    isMFApp: false,
    svcDoc: ,
    eventTypes: [],
    url: "http://167.20.20.123:8080/middleware/MWServlet",
    secureurl: "http://167.20.20.123:8080/middleware/MWServlet"
};

All 4 startup.js look the same when it come to the appConfig. Hope that helps

Martin

Replied by: Feb 02, 2016 09:27 EST
Bronze
Vote up!
3 votes
Vote down!

Hello,

I found the configuration responsible for the entry. See the attached screen shot. The file selected must exist and contain a valid json object. An {} did the trick for me. But I am just doing the training course.

I guess that answers the questions of the OP.

Regards

Martin

Replied by: Feb 02, 2016 10:22 EST
Bronze
Vote up!
1 votes
Vote down!

Hi All,

Thanks for bringing to our notice.

We are able to reproduce above issue only when we login Studio using Cloud credentials. The same is working fine with Studio license file.

A ticket has already been raised for this and team is working. Will keep the post udpated with the details.

Thanks.

Replied by: Feb 03, 2016 02:00 EST
Gold
Vote up!
0 votes
Vote down!

Hi Madhuri,

Any workaround while we wait for the final solutions?

Can we use krischik.martin's suggestion?

 

Thanks!

Replied by: Feb 03, 2016 05:49 EST
Kony Answered Certificate
Vote up!
0 votes
Vote down!

Hi,

Thank you for contacting Kony.

This issue has been resolved in the latest plugins of Kony Studio IDE.

It is solved in IDE GA Plugins 6.5.2_r9.

Kindly check your application in this.

Thank you
Rashmi

Feb 23, 2016 04:44 EST
Gold