Important! A new Community experience launched on September 26, 2017. Read more about it here or continue to Base Camp.
Voting: 
Vote up!
0 Votes
4 Replies

Kony Studio - Atleast one SDK should be installed - Error

NEELAM PUJARI on Mar 22, 2017 14:18 EDT

Posted In
Vote up!
0 votes
Vote down!

Hi Neelam,

Please check if Android Home which is available in Window-->Preferences-->Kony Dev Studio-->Build is updated with Android SDK path. If not, please provide the android SDK path and verify the issue.

Please refer the attached screenshot for reference.

If you have already specify the Android Home,Then please check the Android Build Tools Version which is installed in your SDK Manager.

If Android Build Tools version is 24.0.0 rc1 and above, We request you to downgrade your Android Build Tools Version from 24.0.0 rc1 to 23.0.x version, based on below forum.

http://stackoverflow.com/questions/35990995/com-android-dx-command-main-unsupported-major-minor-version-52-0

Please follow the above solution and share us the screenshot of the build tools which are currently installed if the issue still replicates.

Thanks,

Ravi Kumar

Replied by: Mar 23, 2017 03:47 EDT
Vote up!
0 votes
Vote down!

Thanks Ravi, my android sdk home is set in Kony studio , however I did have the higher version of SDK tools. 

I have downgraded the sdk tools version to 23.0.3 but I am still getting the same error as " atleast one SDK  should be installed " .

I am attaching the screen shots for build tools version as well as my kony studio preferences.

 

Any help would be appreciated.

 

Thanks,

Neelam

Replied by: Mar 27, 2017 10:59 EDT
Vote up!
0 votes
Vote down!

Hi Neelam,

 

You are unable to build application for Android platform while building the application you are getting the prompt error says, AtLeast One SDK should be installed to run the application

I suspect that tools which you are using inside an Android SDK got corrupted, For reference, I have shared the below link which contains tools, please replace the tools folder to the Android SDK and check the behavior.

https://www.sendspace.com/file/fb9xgd

Thank you,

RaviKumarReddy

Replied by: Apr 14, 2017 06:43 EDT
Vote up!
0 votes
Vote down!

FYI..

https://community.kony.com/developer/forum/atleast-one-sdk-should-be-installed-run-application-new-android-sdk-tools-update

Replied by: May 14, 2017 01:02 EDT