Important! A new Community experience launched on September 26, 2017. Read more about it here or continue to Base Camp.
Voting: 
Vote up!
1 Votes
11 Replies

duplicate symbols

Alexander Gonzales on Mar 04, 2016 16:26 EST

Posted In
Vote up!
0 votes
Vote down!

Hi Alexander,

We understand you are facing some errors while launching in iPhone/iPad.

As per the Error logs, Can you please check if you are using #import a .m file instead of the .h!

Generally, this kind of error occurs due to duplicate classes and xibs in your project folder. We can see these duplicate classes under target->Build phases->compile sources.

Kindly look and remove extra classes.

Please refer the below links for more information on this,
http://stackoverflow.com/questions/16427024/duplicate-symbols-for-architecture-armv7

http://stackoverflow.com/questions/25123776/ld-xx-duplicate-symbols-for-architecture-armv7-xcode-project

http://angelolloqui.com/blog/31-How-to-fix-a-Duplicated-Symbols-error-on-binary-files

Please refer the above links and if you are still facing the same problem we would request you to share us your codebase with FFI Library with steps to replicate and debug the issue from our side.

Thank you
Rashmi

Replied by: Mar 07, 2016 01:05 EST
Gold
Vote up!
0 votes
Vote down!

I am not sure how you would reproduce as it would require getting the code base from a secure git, running it in R23 then upgrading to R24.

Also your answer is confusing to me, I am getting this log and error in Kony Studios.

The xcode is never brought up, I have a VMAppWithKonylib for R23 but the R24 VMAppWithKonylib has never opened. so i am unable to check xcode for an import statement that would have .m instead of .h. I suppose its possible that Kony studios decided to create the wrong import statement but i dont know how to check. 
Also i can not find target->Build phases->compile sources in Kony Studios Yes i know where it is in xcode but again Xcode with VMAppWithKonylib r24 never runs and there doesn't seem to be anything wrong with VMAppWithKonylib r23

To be clear i am stopped in Kony Studios. In studios I run clean and build then once i have a check mark on iPhone I right click it select Launch, then I get the above issue. Xcode never opens. 

Replied by: Mar 07, 2016 09:04 EST
Vote up!
0 votes
Vote down!

Hi,

I'm experiencing the same error after updating to the last r24 version iOS plugin. And the problem seems to be reproduced only launching from Kony Studio, if I go to my workspace, search for the plugin folder and open manually the xcodeproj generated on the VMAppWithKonylib folder, works. Maybe it can be fixed configuring something on Kony Studio but it is not a problem about something configured from the developer side.

To add more info, If I create a new simple project with nothing more than one empty form, fails in a simple "Build & Launch" operation.

Greetings,

Ricardo.

Replied by: Mar 07, 2016 12:03 EST
Vote up!
0 votes
Vote down!

Hi,

Thank you for your update.

We have tried replicating this issue using a simple application. It is not replicable at that time.

Hence we are asking you to kindly share your KAR file atleast so that we can replicate the issue and give you a better solution.

Regards,

Rashmi

 

Replied by: Mar 09, 2016 01:37 EST
Gold
Vote up!
0 votes
Vote down!

Attached is the KAR file  This is the KAR file from the folder that is r24

Replied by: Mar 09, 2016 09:11 EST
Vote up!
0 votes
Vote down!

Still having trouble with this in r26 (i never saw r25) 
Let me know if you would like the KAR file of r26 
 

Replied by: Mar 11, 2016 12:37 EST
Vote up!
0 votes
Vote down!

 Hi Team,

We are also facing the same issue with r26 . Kindly do the needful ASAP.

Thanks,

Dipali

Replied by: Mar 16, 2016 02:40 EDT
Kony Answered Certificate
Vote up!
0 votes
Vote down!

Hi,

Thank you for your udpate.

This issue is currently being addressed by our product Engineering team.

We were able to observe that with the latest iOS-GA-6.5.2-r25/r26 plugin and when we build the application in Debug mode we are getting duplicate error messages and unable to build the application.

We request to you to change the application Release mode and check it once again. Or Go to your Xcode and delete -all_load from the Other Linker Flag under build settings.

Meanwhile, our Engineering team will resolve this issue in the future plugins.

Thank you

Rashmi

Mar 16, 2016 06:59 EDT
Gold
Vote up!
0 votes
Vote down!

Building in release mode worked for me, thanks!

Replied by: Mar 16, 2016 10:11 EDT
Vote up!
0 votes
Vote down!

Hy

I have the same problem, but the plugin version is : iOS-6.5.2.GA_v201603171625_r27

Replied by: Mar 22, 2016 06:37 EDT
Vote up!
0 votes
Vote down!

So from what I could determine, a tempoary work around is to go to the applications tab in studio, hit Shift+CMD+P  to bring up the applications properties, Click the Build tab and change the build ot release. 
This will allow you to run the app, but it wont allow you to use Debug mode. 

Hope this helps 

Replied by: Mar 22, 2016 08:29 EDT