Important! A new Community experience launched on September 26, 2017. Read more about it here or continue to Base Camp.
Voting: 
Vote up!
2 Votes
11 Replies
Answered

Resource is out of sync

Question asked by Wing San Lun on Dec 10, 2015 23:16 EST

Hi, I have created a project in Visualizer and then export the project to Studio. After importing the VZ project and add some codes, I export and import to Visualizer for some UI changes. When I export the project from Visualizer and import to Studio again, I get the following errors:   [12-11-2015 12:12:39]Visualizer Project KerryLog is not imported successfully to Kony Project. Please see error log. org.eclipse.core.internal.resources.ResourceException ocurred at org.eclipse.core.internal.localstore.FileSystemResourceManager.read(FileSystemResourceManager.java:793) Cause: Resource is out of sync with the file system: '/KerryLog/themes/default/windows8skin.xml'. And the project fails to import and lost everything ! How can I import my Visualizer back to Studio successfully?

Vote up!
1 votes
Vote down!

I'm encountering the same issue. Re-importing an existing project from Visualizer to Studio gives this error:

[12-14-2015 12:13:06]Visualizer Project HelloWorld is not imported successfully to Kony Project. Please see error log.
org.eclipse.core.internal.resources.ResourceException ocurred at org.eclipse.core.internal.localstore.FileSystemResourceManager.read(FileSystemResourceManager.java:793)
Cause: Resource is out of sync with the file system: '/HelloWorld/themes/default/windows8skin.xml'.
[12-14-2015 12:13:06]Visualizer Project HelloWorld is not imported successfully to Kony Project. Please see error log.

 

What's the best process to follow when going back and forward from Studio to Visualizer? The bootcamp implies that doing so can break things in your project - but going back and revising your design is a crucial part of any rapid development workflow - there needs to be a simple and error-free method of doing this.

I notice that even when importing to a new project in Studio, my module files are not imported and I have to manually add them again. Same with my services.

Selecting 'New & Merge' during import seems to import everything correctly, but then I'm left with a completely new project, rather than updating my existing one..

This process also seems to be a nightmare from a collaboration and source control point of view. Given the problems I'm having just importing locally, I can't imagine a merge process going smoothly if I've modified the UI in Visualizer whilst other developers have continued working on it in Studio. Multiple local projects for the UX and Development tools also make source management a headache. Perhaps I'm missing something about this (extremely common) workflow...

Replied by: Dec 13, 2015 21:34 EST
Vote up!
2 votes
Vote down!

Same problem here ("Resource is out of sync with the file system: '/HalloWorld/themes/default/skin.xml").

What i have tried: Refreshed the work space, Closed and opend the Studio again, Deleted and imported the Visualizer project again, Deleted old and made a new export for Studio, but still no luck. The problem is: "The skin references for widgets were protected but the skins were lost in imported Studio IDE".

  1. Did it ever worked switching the work between Visualizer and Studio?
  2. Is it because of the new Studio version (6.5)?
  3. Do i manually have to copy the Skins?

Quick response is appreciated :)

Best Regards.

Replied by: Dec 14, 2015 10:35 EST
Vote up!
1 votes
Vote down!

Hello All,

Apologies for the inconvenience you are facing.

But switching between visualizer and studio should not create above skin issues or loosing the data issues. Manually copying the skins is not required. We are frequently working and could not see any such issues.

We can understand the you are following below steps but just wanted to confirm if you have followed.

1) Please make sure that Visualizer IDE version and Visualizer plugin in Stuion IDE are in sync.

2) When exporting visualizer project, please export only by selecting the project ----> Project menu ----> Export ----> Save the project in .zip format.

3) Now in Studio IDE, right click under Applications tab ----> Import ----> Import from Visualizer ---> select the above .zip file.

Request you to please provide your visualizer project along with your visualizer version and studio plugins, error screenshot so that we can test and check the issues you are facing.

Thanks.

Replied by: Dec 16, 2015 06:30 EST
Gold
Vote up!
0 votes
Vote down!

May I have your email address as the project is confidential ?

Replied by: Dec 16, 2015 08:09 EST
Vote up!
1 votes
Vote down!

Thank you Madhuri, It worked for me. The fix was: I have updated my Visualizer as well to 2.5.2.5 (which has exact fix for my problem). Although i have to reopen my Studio IDE after Visualizer project import as it is behaving strange for App build. (Asking me to define the "Start up" although i have defined one).

Replied by: Dec 16, 2015 10:41 EST
Vote up!
1 votes
Vote down!

Hi Madhuri,

It seems to be working for me now as well. My Visualizer version is also 2.5.2.5 (same as Sri), so it seems whatever was causing this is fixed in the latest version.

Thanks.

Replied by: Dec 20, 2015 19:16 EST
Vote up!
0 votes
Vote down!

Hi,

 

It still does not work. I have updated both VZ and VS to the latest version. For VZ, it is 2.5.2.5 and I have applied the updates for VS yesterday. If you give me the email address, I can send the VZ and VS for you.

Replied by: Dec 20, 2015 22:58 EST
Vote up!
0 votes
Vote down!

Hi Wing,

Apologies for the delay.

Please send the details to madhuri.choutkur@kony.com

Along with the applciation, send the screenshots of visualizer version, kony plugin details. Also let us know if the project was initially developed using Visualizer 2.5 OR it was upgraded in visualizer 2.5 from the lower version. If yes what the earlier visualizer version the app was developed.

Thanks.

Replied by: Dec 21, 2015 05:16 EST
Gold
Kony Answered Certificate
Vote up!
0 votes
Vote down!

Hi Wing,

Thanks for providing all the details that helps us in replicating the same. I have even tried creating new app in visualizer. Without any modifications tried exporting and importing into Visualizer and Studio multiple times. Even in this case i could see the error. Tested in Visualizer version (2.5.2.5) along with attached kony plugins.

"Resource is out of sync with the file system" is generally the error that we get in eclipse when a file is being hold by some other resource. This seems to be the errror due to environment.

As discussed with product team, i have closed all the opened windows, restarted studio and visualizer. In this case, the issue was not happening even after multiple export/import from visualizer to studio.

Can you please try restarting and check if you are still facing the issue.

Also to know the exact cause of the error, team needs to debug. If you are still facing the issue, request you to raise ticket in support portal providing all the details. If you are unable to raise then let us know so that we can raise on your behalf.

Sorry for the inconvenience.

Thanks.

Answered by: Dec 22, 2015 08:10 EST
Gold
Vote up!
0 votes
Vote down!

Hi,

When iam trying to import my project from visualizer to kony studio button skins are not applied can you please help me .(visualizer version is 2.5.2.5 and studio version 6.5) its urgent please.

Thank you in advance.

Replied by: Feb 13, 2016 06:23 EST
Vote up!
0 votes
Vote down!

Hi,

Thank you for contacting Kony.

Kindly check all the below points.

1) Please make sure that Visualizer IDE version and Visualizer Integration plugin in Studio IDE are in sync. As your Visualizer version in 2.5.2.5, the Visualizer plugin should be 6.5.2_r5. (Attaching our plugins)

2) When exporting visualizer project, please export only by selecting the project ----> Project menu ----> Export ----> Save the project in .zip format.

3) Now in Studio IDE, right click under Applications tab ----> Import ----> Import from Visualizer ---> select the above .zip file.

4) Close all the open forms in the Visualizer and re-start your Visualizer to check again.

Hope to have answered your query.

Thank you
Rashmi

Replied by: Feb 15, 2016 02:12 EST
Gold