Voting: 
Vote up!
0 Votes
8 Replies
Answered

Generation of Blackberry cod file is failed

Question asked by on Oct 25, 2010 05:03 EDT

If you get an error similar to the one below [copy] Copying 4 files to D:\eclipse\workspace\temp\<project>\build\luaj2me\blackberry Ant build error=exec returned: 1 Generation of Blackberry cod file is failed The possible causes could be: 1) the application logo file is of very large size (dimensions like 480x540) 2) "javac" is not in system path. For more detailed info we can look at the *rapc.log files under <eclipse-workspace>\temp\<appname>\build\luaj2me\blackberry <eclipse-workspace>\temp\<appname>\build\luaj2me\blackberry-47

Vote up!
0 votes
Vote down!

Build failed for 4.7 and 4.2 :

What might be the cause for this? The same code never gave this error before with the same plugins.

rapc.log in blackberry :

Populating
I/O Error: output file: HLBPhase1SIT.cod data section too large: 94568 bytes.


D:\Chiranjeevi_Workspace\temp\SITNew4\build\luaj2me\blackberry\dist>copy /y HLBPhase1SIT.cod HLBPhase1SIT-bb-rel.cod
The system cannot find the file specified.

D:\Chiranjeevi_Workspace\temp\SITNew4\build\luaj2me\blackberry\dist>copy /y HLBPhase1SIT.csl HLBPhase1SIT-bb-rel.csl
The system cannot find the file specified.

D:\Chiranjeevi_Workspace\temp\SITNew4\build\luaj2me\blackberry\dist>copy /y HLBPhase1SIT.cso HLBPhase1SIT-bb-rel.cso
The system cannot find the file specified.


rapc.log in blackberry 47:

logo.png: Error!907: Icon data is too large: 43758 bytes

D:\Chiranjeevi_Workspace\temp\SITNew4\build\luaj2me\blackberry47\dist>copy /y HLBPhase1SIT.cod HLBPhase1SIT-bb-47-rel.cod
The system cannot find the file specified.

D:\Chiranjeevi_Workspace\temp\SITNew4\build\luaj2me\blackberry47\dist>copy /y HLBPhase1SIT.csl HLBPhase1SIT-bb-47-rel.csl
The system cannot find the file specified.

D:\Chiranjeevi_Workspace\temp\SITNew4\build\luaj2me\blackberry47\dist>copy /y HLBPhase1SIT.cso HLBPhase1SIT-bb-47-rel.cso
The system cannot find the file specified.

Replied by: May 02, 2011 16:56 EDT
Vote up!
0 votes
Vote down!

Check if the logo image you have added is very very large. Check if you have added a PNG image whose size is greater than 64KB.

generally a single image should not be greater than 64KB.

Replied by: May 02, 2011 17:00 EDT
Vote up!
0 votes
Vote down!

The logo file you provided is very large (width and height). generally it should be 54x54.

Replied by: May 02, 2011 17:02 EDT
Vote up!
0 votes
Vote down!

Yes, icon.png is 80x80. Do we need to change the icon to 54x54? and also, is this dimensions standard to be followed for all the other assets or only for icon iamges?

But the same plugins gave no error previously.

Replied by: May 02, 2011 17:08 EDT
Vote up!
0 votes
Vote down!

whats the size (bytes) of the logo file ?

Replied by: May 02, 2011 17:11 EDT
Vote up!
0 votes
Vote down!

6.20 KB

Replied by: May 02, 2011 17:27 EDT
Vote up!
0 votes
Vote down!

That does not seem to right as it is reporting 43758, Check if you have overridden the logo file for storm.

Replied by: May 02, 2011 17:30 EDT
Vote up!
0 votes
Vote down!

Thank you. Yes. Previously, copied & replaced into resources.

Deleting and pasting assets solved the issue.

Replied by: May 02, 2011 17:39 EDT