Important! A new Community experience launched on September 26, 2017. Read more about it here or continue to Base Camp.
Voting: 
Vote up!
1 Votes
15 Replies
Answered

cloud Kony vs WindowsPhone

Question asked by Francisco Souza on May 15, 2015 08:09 EDT

Hi All   I'm facing by a connection problem with windows phone. Scenario: 1)I've my services published at cloud Kony (integration services). 2)I've the code that connect properlly  into the endpoint (https://100004851.auth.konycloud.com/appconfig) that use the AppKey and AppSecret provided from mobileFabric dashboard and the code connection for KonyStudio, as bellow: konyObject = new kony.sdk(); konyObject.init(AppKey,AppSecret,"https://100004851.auth.konycloud.com/appconfig",successCallback, errorCallback); The code provides has been working properlly for iOS and Android (smartPhone and tablet) But doesn't connect for Windows Phone (windows phone v 8.1).  Do your have any tip about it ?   I'm getting the following error bellow:    <u>Unsupported Media Type</u></p><p><b>description</b> <u>The server refused this request because the request entity is in a format not supported by the requested resource for the requested method (Unsupported Media Type).</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/7.0.26</h3>       The complete Log:   2015-05-14 16:52:46,154 - Platform Information Response from url :https://100004851.auth.konycloud.com/login?provider=$anonymousProvider StatusCode : 415 StatusDescription : Unsupported Media Type ContentType : Document Response : <html><head><title>Apache Tomcat/7.0.26 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 415 - Unsupported Media Type</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>Unsupported Media Type</u></p><p><b>description</b> <u>The server refused this request because the request entity is in a format not supported by the requested resource for the requested method (Unsupported Media Type).</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/7.0.26</h3></body></html> 2015-05-14 16:52:46,171 - User Information "result is {"status":415,"statusText":"Unsupported Media Type","responseType":"document","response":"<html><head><title>Apache Tomcat/7.0.26 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 415 - Unsupported Media Type</h1><HR size=\"1\" noshade=\"noshade\"><p><b>type</b> Status report</p><p><b>message</b> <u>Unsupported Media Type</u></p><p><b>description</b> <u>The server refused this request because the request entity is in a format not supported by the requested resource for the requested method (Unsupported Media Type).</u></p><HR size=\"1\" noshade=\"noshade\"><h3>Apache Tomcat/7.0.26</h3></body></html>","readyState":4}" 2015-05-14 16:52:46,187 - User Information "readyState is 4" 2015-05-14 16:52:46,193 - User Information "status is 415" 2015-05-14 16:52:46,199 - User Information "### AuthService::login login failure. retrieved data:: " 2015-05-14 16:52:46,212 - User Information "<html><head><title>Apache Tomcat/7.0.26 - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 415 - Unsupported Media Type</h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u>Unsupported Media Type</u></p><p><b>description</b> <u>The server refused this request because the request entity is in a format not supported by the requested resource for the requested method (Unsupported Media Type).</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/7.0.26</h3></body></html>" 2015-05-14 16:52:46,229 - User Information "### AuthService::login Calling failure callback"

Vote up!
0 votes
Vote down!

Hi,

We are working on this as part of a support ticket. Mostly this would be a device specific issue (Windows  Phone V 8.1) where as this would not be an issue with Windows Phone V 8 . 

Anyways we will update you on your issue very shortly.

Thanks,

Naresh

Replied by: May 18, 2015 04:19 EDT
Vote up!
0 votes
Vote down!

Thanks Naresh for your reply. Sounds weird to me this functionality doesn't work in WPhone V8.1 and works for a prior version. Note that I'm using the code provided by Kony from Kony Cloud page. It's just a copy & paste. As I said, this works for iOS and Android properly. How can I escalate this ticket or change priority of that ?

Replied by: May 18, 2015 04:36 EDT
Vote up!
0 votes
Vote down!

Hi,

Team is working on it. Please provide your responses in the ticket as soon as possible so that the team will respond to you faster.

Thanks,

Naresh

Replied by: May 19, 2015 01:57 EDT
Vote up!
0 votes
Vote down!

Naresh

 

I tried another test. Replaced the file kony-sdk.js of my project (created by default) by the kony-sdk.js file available in the cloud kony. 

Ran the test and I got the same error.

 

This become critical for us. 

Replied by: May 19, 2015 14:46 EDT
Vote up!
0 votes
Vote down!

Hi,

We Understood your criticality. We forwarded the request to our engineering team, They are working on it. They will get back to you shortly, please update in that support ticket if you have any.

Thanks,

Naresh

Replied by: May 20, 2015 06:09 EDT
Vote up!
0 votes
Vote down!

Any update as I'm facing the same problem?

Regards
Mark...

Replied by: Jun 15, 2015 05:47 EDT
Vote up!
0 votes
Vote down!

Hi,

This issue has been addressed in the GA kony-sdk 6.0.3.2. This can be downloaded from the portal (https://manage.kony.com).

 

Regards,

Rais Ahmad

Replied by: Jun 19, 2015 06:37 EDT
Vote up!
0 votes
Vote down!

Hi all

We validated but it not is done! The bug fix don´t resolved the problem.

 
An attention point, the version of the bug fix in corresponded file has the follow information:
 
Kony-Version=mBaaSSDK-GA-6.0.3.2
Build-Date=20150511
Build-Time=1232

 
The Build-Date is older, is right?
 
Regards,

Delano

Replied by: Jun 19, 2015 15:33 EDT
Vote up!
0 votes
Vote down!

Hi all

We validated but it not is done! The bug fix don´t resolved the problem.

 
An attention point, the version of the bug fix in corresponded file has the follow information:
 
Kony-Version=mBaaSSDK-GA-6.0.3.2
Build-Date=20150511
Build-Time=1232

 
The Build-Date is older, is right?
 
Regards,

Delano

Replied by: Jun 19, 2015 15:33 EDT
Vote up!
0 votes
Vote down!

Hi Delano,

Are you using the latest windows phone plugins. Can you please share us the screenshot of your IDE plugin details.

Also can you let us know the error message that you are getting. 

Thanks,

Naresh

Replied by: Jun 22, 2015 03:33 EDT
Vote up!
0 votes
Vote down!

Hi Naresh

Follow below the plugins used in project. If you need more information, tell us!

    <pluginInfo version-no="6.0.3.GA_v201503251356" plugin-id="com.pat.tool.keditor.KEditorPlugin" plugin-name="Kony Studio"/>
    <pluginInfo version-no="6.0.3.GA_v201503251251" plugin-name="Third Party Jars Plug-in"/>
    <pluginInfo version-no="6.0.3.GA_v201503251251" plugin-id="com.pat.soapui.SoapUIPlugin" plugin-name="Soap UI Plugin"/>
    <pluginInfo version-no="6.0.3.GA_v201503251259" plugin-name="Kony Codegenerator"/>
    <pluginInfo version-no="6.0.3.GA_v201503251255" plugin-id="com.kony.nativecodegen.NativeCodeGenPlugin" plugin-name="Nativecodegen"/>
    <pluginInfo version-no="6.0.3.GA_v201503251251" plugin-name="Kony Studio Licensing"/>
    <pluginInfo version-no="6.0.3.GA_v201503261240" plugin-id="com.kony.cloudmiddleware.Activator" plugin-name="CloudMiddlewarePlugin"/>
    <pluginInfo version-no="6.0.3.GA_v201503261240" plugin-id="com.kony.cloudthirdparty.Activator" plugin-name="CloudThirdPartyPlugin"/>
    <pluginInfo version-no="6.0.3.GA_v201503251754" plugin-id="com.viz.ide.VisualiserIDEPlugin" plugin-name="Visualizer Integration Plugin"/>
    <pluginInfo version-no="6.0.3.GA_v201503251722" plugin-id="com.kony.studio.cloud.StudioCloudPlugin" plugin-name="Kony Studio Cloud Integration"/>
    <pluginInfo version-no="6.0.3.GA_v201503251722" plugin-id="com.kony.studio.sky.SkyPlugin" plugin-name="Sky Data Explorer"/>
    <pluginInfo version-no="6.0.3.GA_v201503251758" plugin-name="Functional Preview Plugin"/>
    <pluginInfo version-no="6.0.3.GA_v201503261654" plugin-id="com.pat.android.Activator" plugin-name="Tablet Android"/>
    <pluginInfo version-no="6.0.3.GA_v201503251719" plugin-id="com.pat.j2me.J2MEPlugin" plugin-name="Blackberry &amp; J2ME"/>
    <pluginInfo version-no="6.0.3.GA_v201503251839" plugin-id="com.kony.bb10.BB10Plugin" plugin-name="Blackberry 10"/>
    <pluginInfo version-no="6.0.3.GA_v201503251729" plugin-id="com.kony.windows.WindowsPhone8Plugin" plugin-name="Windows Phone 8 Plug-in"/>
    <pluginInfo version-no="6.0.3.GA_v201503251749" plugin-id="com.kony.windows.Windows8Plugin" plugin-name="Windows 8.1 Plug-in"/>
    <pluginInfo version-no="6.0.3.GA_v201503261654" plugin-id="com.pat.android.Activator" plugin-name="Android"/>
    <pluginInfo version-no="6.0.3.GA_v201503251801" plugin-id="thinclientplugin.Activator" plugin-name="ThinClient"/>
    <pluginInfo version-no="6.0.3.GA_v201503261007" plugin-id="com.kony.windows.WinDesktopPlugin" plugin-name="Windows Desktop Plug-in"/>
    <pluginInfo version-no="6.0.3.GA_v201503251734" plugin-name="SPA"/>
    <pluginInfo version-no="6.0.3.GA_v201503261140" plugin-name="Desktop Web"/>
    <pluginInfo version-no="6.0.3.GA_v201503252210" plugin-id="com.kony.sync.ide.SyncPlugin" plugin-name="Kony Sync"/>
    <pluginInfo version-no="6.0.3.GA_v201503251811" plugin-id="com.kony.web.Activator" plugin-name="Kony Web Commons"/>
    <pluginInfo version-no="6.0.3.GA_v201503250510" plugin-id="iosplugin.Activator" plugin-name="iOS Plugin"/>
    <pluginInfo version-no="6.0.3.GA_v201502181720" plugin-id="com.kony.mobile.fabric.client.sdk.MBaasSDKPlugin" plugin-name="MobileFabric Client SDK"/>
 
Regards

Replied by: Jun 22, 2015 18:17 EDT
Vote up!
0 votes
Vote down!

Hi,

Thanks for sharing us the plugin details. We are working in this as part of a support ticket. If possible can you share us the error message that you are receiving.

Thanks,

Naresh

Replied by: Jun 23, 2015 09:09 EDT
Vote up!
0 votes
Vote down!

Hi Naresh,

 

Follow below the scenario´s information and the error:

 

Regards

Delano

 

I'm facing by a connection problem with windows phone.

Scenario:

1)I've my services published at cloud Kony (integration services).

2)I've the code that connect properlly  into the endpoint (https://100004851.auth.konycloud.com/appconfig) that use the AppKey and AppSecret provided from mobileFabric dashboard and the code connection for KonyStudio, as bellow:

konyObject = new kony.sdk();
konyObject.init(AppKey,AppSecret,"https://100004851.auth.konycloud.com/appconfig",successCallback, errorCallback);

The code provides has been working properlly for iOS and Android (smartPhone and tablet) But doesn't connect for Windows Phone (windows phone v 8.1).  Do your have any tip about it ?

 

I'm getting the following error bellow: 

 

<u>Unsupported Media Type</u></p><p><b>description</b> <u>The server refused this request because the request entity is in a format not supported by the requested resource for the requested method (Unsupported Media Type).</u></p><HR size="1" noshade="noshade"><h3>Apache Tomcat/7.0.26</h3>

Replied by: Jun 23, 2015 09:36 EDT
Vote up!
0 votes
Vote down!

Hi,

Sorry for the delay in response. We are working on this as part of a support ticket. So we will let you know the resolution soon.

Thanks,

Naresh

Replied by: Jul 03, 2015 09:31 EDT
Kony Answered Certificate
Vote up!
0 votes
Vote down!

Hi,
 
We have tested it with mBaaS-SDK-6.0.3.2 plugin. We are able to do a successful init using kony Cloud.
 
Please find the attached snippet for the plugin set used for testing.
 
Thanks,
Naresh

Answered by: Jul 08, 2015 05:09 EDT