Important! A new Community experience launched on September 26, 2017. Read more about it here or continue to Base Camp.
Voting: 
Vote up!
3 Votes
6 Replies
Answered

Cannot Publish MobileFabric after built SPA app

Question asked by MUNUAR.BASHA on May 24, 2016 05:55 EDT

I have created a Service using MobileFabric. After successfully built SPA a File "appname.war" is created on Web tab of Manage Client App Assets Tab. If I try to publish this MobileFabric Cloud App, I am getting this error message "Internal Error. Failed to check Server state - Failed to propagate Integration Services to Runtime. Status [deploy_failed]". If I remove Web Client ("appname.war") from MobileFabric, my app is getting published successfully.  Please help me out!.

Posted In
Kony Inc Kony Fabric
Tags:
Vote up!
0 votes
Vote down!

Can you please share logs from MobileFabric (please zip up and share MobileFabricFolder/logs)?

Replied by: May 26, 2016 06:58 EDT
Vote up!
0 votes
Vote down!

Hi Ajay,

Please find the attached file. 

NOTE:

Suppose my Mobile Fabric app being olny with .war file(Without any service configuration), the upload get succeeding but SPA application page being white(Nothing Showing). 

Thanks.

Replied by: May 31, 2016 01:23 EDT
Vote up!
0 votes
Vote down!

Did you find a solution to this problem? Care to share how you solved it?

Replied by: Jun 17, 2016 03:10 EDT
Vote up!
0 votes
Vote down!

Hi Basha,

As per the error mentioned, it is failed at app server while deployment, please share app-server & all Mf component logs. please answer below queries.

What is the app server you are using ?

have you configured any specific connector(like SAP) in viz IDE ?

Thanks,

Bharat.

Replied by: Jul 13, 2016 08:06 EDT
Vote up!
0 votes
Vote down!

Can you please share the answer for this query? Even I am facing similar issue. Kindly do share the answer on how to resolve the issue.

Replied by: Feb 06, 2017 12:14 EST
Vote up!
0 votes
Vote down!

Ajay R, we need more details to address the issue at hand. Please share details of your issue in a SEPARATE query, with the following information:

 

1. Version of MobileFabric. If it's on-prem, please mention app server used with version.

2. Version of Kony Studio / Visualizer

3. Specific services used ( a sample app where you can reproduce the issue would be helpful)

4. MobileFabric logs

Replied by: Feb 07, 2017 01:24 EST