Solved

Cloud middleware url '' is invalid

Problem posted by Martin Krischik on Dec 03, 2015 07:33 EST

Another try (commandline build) and another strange error. This time: [exec] Cannot run program "wmic": error=2, No such file or directory [exec] Unable to compute unique identifier for the system. Default identifier will be used. [exec] Argument: /Users/krma1/Work/Projects/Main/Sources/KPTnetApp/build.properties [exec] Workspace Loc: /Users/krma1/Work/Projects/Main [exec] Cloud middleware url '' is invalid. We don£t use...

View all replies

Hi Martin, We understand that you have already raised a support portal ticket for this issue. Our team will be working...

View full answer

Solved by: Rashmi Menon May 10, 2016
Answered

How to make use of FFI for android library project

Question asked by Pritam Shah on Jun 01, 2015 06:08 EDT

I want to make use of open source "Tessarct" engine for doing an OCR inside Kony apps. In native android development it can be added as a library project in Eclipse workspace, and build your project making use of it. https://github.com/rmtheis/android-ocr How do we achieve same in Kony ? Is there any way to make...

View all replies

Hi,   please follow the below steps to integrate library project into kony application.   Let us assume that you are trying to use...

View full answer

Answered by: Naresh Nalamolu Jun 03, 2015
Answered

Popup and Line Widget in Kony 6.0

Question asked by gopinath gopinath on Feb 27, 2015 01:03 EST

Hello Team, I'm on the very latest kony 6.0 plugins.  I need kony's design recommendations for the following - 1. Can we still use Kony Popup in Kony 6.0? I'm using only Flex forms in my application.Or does Kony recommend using flex containers/scroll containers with z index property a) If we go with the approach to set the z index then how do we...

View all replies

Hi Gopinath, Please find the details below. 1) As confirmed by team,  we can still use popup layouts on flex forms to...

View full answer

Answered by: Madhuri Choutkur Mar 09, 2015
Answered

Android x86 Preview

Question asked by Mark Newton on Jul 22, 2014 06:22 EDT

Hi If I Preview a Form using an Android Emulator (Google APIs / 4.4.2 (API19) / CPU Intel Atom (x86)) then I get "Error Code 100: Unexpected error" as soon as the Preview App tries to render. Works fine on an Android Emulator using 4.4.2 (API19) but with CPU ARM (armeabi-v7a). I have x86...

View all replies

Hi Mark, As of now preview and auto preview functionalities are not supported using Android X86 Emulator. Ticket is updated with...

View full answer

Answered by: Madhuri Choutkur Sep 19, 2014
Answered

JSON response with unnamed array of values

Question asked by wbagley on Dec 11, 2013 16:21 EST

I am trying to call a REST web service that returns an array of values in JSON format. The JSON has the general format: [ {some data}, {some data} ] This is perfectly valid JSON as verified by jsonlint.com. However I am having trouble telling the Kony server how to parse...

View all replies

Please check if the below post:http://developer.kony.com/konyforum/viewtopic.php?pid=12570

View full answer

Answered by: Gandhi Gannamaneni Jan 10, 2014
Answered

pdf in Browser Widget

Question asked by kannan.veeraraghavan on Dec 16, 2011 05:53 EST

How to set base-64 encoded pdf to browser widget? or how to display pdf in our app?

View all replies

Answered

Sometimes application cannot be built

Question asked by Venkat Alagarsamy on Jul 09, 2014 07:12 EDT

Hi Kony Team,                           When i try to build and launch the application, sometimes it is not built and showing the following error. Please suggest solutions to fix it. [07-09-2014 04:33:36]java.lang.NullPointerException     at com.pat.tool.keditor.KEditorPlugin.getJettyHttpsPortNumber(KEditorPlugin.java:1670)     at com.pat.tool.keditor.actions.ResourceActionHelper.readPeferences(ResourceActionHelper.java:6290)     at com.pat.tool.keditor.actions.ResourceActionHelper.runTasks(ResourceActionHelper.java:789)     at com.pat.tool.keditor.actions.BuildFromEmulatorAction.run(BuildFromEmulatorAction.java:52)     at org.eclipse.ui.actions.BaseSelectionListenerAction.runWithEvent(BaseSelectionListenerAction.java:168)     at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:584)     at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:501)     at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:411)   Many thanks.

View all replies

Actually the issue was not with the plugins or misconfigurations, i have resolved it by signing out of the kony...

View full answer

Answered by: Venkat Alagarsamy Jul 23, 2014
Answered

Cannot Publish MobileFabric after built SPA app

Question asked by MUNUAR.BASHA on May 24, 2016 05:55 EDT

I have created a Service using MobileFabric. After successfully built SPA a File "appname.war" is created on Web tab of Manage Client App Assets Tab. If I try to publish this MobileFabric Cloud App, I am getting this error message "Internal Error. Failed to check Server state - Failed to propagate...

View all replies

Solved

Prefernces - iOS - base SDK version causes a Java Exception

Problem posted by Sa'ad Raouf on Oct 14, 2015 16:40 EDT

Greetings. Attempting to set the Base SDK version using the Refresh button produces a java exception. Exception details: java.lang.StringIndexOutOfBoundsException: String index out of range: -1     at java.lang.String.substring(String.java:1947)     at com.pat.tool.keditor.utils.IOSBuildUtils.getSdkAndSimulatorTypesForXcode6(IOSBuildUtils.java:249)     at com.pat.tool.keditor.preferences.IOSPreferencePage$CustomSelectionAdapter$3.run(IOSPreferencePage.java:569)     at org.eclipse.jface.operation.ModalContext$ModalContextThread.run(ModalContext.java:121)   See the attached screenshot. Using Kony Studio version 6.5     Kony Studio Core IDE    6.5.1.GA_v201507231955    com.kony.core.feature.group    Kony, Inc.       Kony IDE...

View all replies

Solved

Using Map widgets and calloutTemplate with Visualizer

Problem posted by Martin Krischik on Apr 27, 2016 05:14 EDT

Hallo, There seem be quite a lot of bugs surounding the map widget in visualizer. This all seem to be all very buggy. A calloutTemplate in Visualizer need to start with HBox or a FlexForm. Which is pretty useless. In the course I have learned that FlexForms do not actualy work and a VBox would far...

View all replies

Hi Martin, For any queries during your online training, you can send a mail to trainingonlinesupport@kony.com You can also send the link...

View full answer

Solved by: Rashmi Menon May 02, 2016

Pages