Unanswered

Visualizer Enterprise 7.2 showing blank screen while launching

Question asked by shivakumars1 on Jan 04, 2017 07:00 EST

I getting white blank screen while launching Visulaizer, I tried "Run as Administrator" option, and still its showing the same.

View all replies

Hi Shivakumar, 1) Close Visualizer Enterprise. Delete contents from .cache folder under <InstallationPath>\Kony_Visualizer_Enterprise. 2) Open Command prompt and execute below commands from...

View full answer

Answered by: Madhuri Choutkur Jan 05, 2017
Answered

kony.application.openURL not opening URL with # on iOS

Question asked by Martin Krischik on Dec 21, 2016 08:27 EST

Could it be that kony.application.openURL can't openen a URL with an # on iOS? It works fine on Android but fails on iOS. Which is kind of strange.

View all replies

Hi Martin, Can you please check the URL which you are passing to the browser widget is encoded URL and decoded...

View full answer

Answered by: Shaik Mohammad Jabiulla Dec 21, 2016
Answered

Open Project Failed! Asserting theme structure failed

Question asked by steve on Dec 10, 2016 18:35 EST

Hi Guys Not sure what went wrong here. I have been working on a project, been able to publish previews. last change I made was import a button I created from photoshop (first time I have done that). PS: I was working on Visualizer Starter, but I do have Enterprise too. Tried to...

View all replies

For anybody who has a similar problem here what I found out. When looking the themes directory I noticed two directories...

View full answer

Answered by: Martin Krischik Jan 20, 2017
Solved

Segment View Type Page not work on Windows Phone Visualizer 6.5

Problem posted by Falk Hebstreit on Dec 08, 2016 11:14 EST

Hi Alltogether, I have a task into my Certification: To deliver on four plattforms a view witht a paged segment within a flexbox. Some other widgets are inside, buttons labels etc... If I set the segment to View Type => Page Android, iPhone works fine. Even as SPA in a Browser (besids...

View all replies

Hi Falk Hebstreit, Based on the steps provided by you, we have created sample app with hierarchy as flxForm ---> flxContainer...

View full answer

Solved by: Madhuri Choutkur Dec 14, 2016
Answered

how to create a text file in phone

Question asked by karthikc on Nov 18, 2016 05:30 EST

The code below i am using for creating the file but the file is not being created. var path =kony.io.FileSystem.getDataDirectoryPath(); myfile = kony.io.FileSystem.getFile(path+"/myfile.txt"); function saveImageToFile() { var imgData ="baase64data";     myfile.createFile();  var dataAdded = myfile.write(imgData,true); alert("IS DATA ADDED >>>>>>>"+dataAdded); }

View all replies

Hi Karthik, Please find the code for creating the file in the device, var path =kony.io.FileSystem.getDataDirectoryPath(); myfile = kony.io.FileSystem.getFile(path+"/myfile.txt"); function saveImageToFile() {     var imgData ="/9j/4AAQSkZJRgABAgEAYABgAAD/7gAOQWRvYmUAZAAAAAAB/+";//Pass...

View full answer

Answered by: Shaik Mohammad Jabiulla Nov 18, 2016
Answered

Error while setting component orientation

Question asked by Vadivel Anandh on Nov 17, 2016 04:32 EST

Hi, I have Kony Visualizer Enterprise7.2, while getting started at the first time it throws error message like functionalPreviewPort and nodeportnumber are already exist, so I changed the port number from default to 9999 and 5050 after that a new error was thrown by Enterprise as Start up failed please check...

View all replies

Answered

Custom fonts not found for SPA

Question asked by Martin Krischik on Nov 14, 2016 05:44 EST

When looking at the log output for SPA tests I noticed that the custom font is not found: Result : [object Object] konyframework.js:22 GET http://xxxxx02.local:8080/BB1750/spaipad/MaterialDesign/SF-UI-Text-Regular.ttf 404 (Not Found)setHeight @ konyframework.js:22initialize @ konyframework.js:22initializeFormScroller @ konyframework.js:22(anonymous function) @ konyframework.js:31show @ konyframework.js:31kony.ui.Form2.show @ konyframework.js:50showstartupform @ app.js:1$KI.setappevents @ konyframework.js:6a @ konyframework.js:30themeCallBack @ app.js:1e.onerror @ konyframework.js:23 konyframework.js:1 onreadystatechange:...

View all replies

Posted In
Kony Inc Kony Studio

Hi Martin, Please find attached sample application and screenshot to test fonts(SF fonts) in SPA application. We are able to see...

View full answer

Answered by: Madhuri Choutkur Nov 22, 2016
Solved

animationEnd called not called iOS

Problem posted by Martin Krischik on Nov 14, 2016 04:30 EST

Hello, I noted a problem with the newest Kony 6.5 on iOS. The animationEnd method is not called in at least one case. Here the method in question (If you do the certifiaction don't copy what I did):  /** * called when delete button was clicked. Should delete current entry from shopping cart *...

View all replies

Hi Martin, Please find the sample application available in the below link that showcases animations. We could see that "animationEnd" is...

View full answer

Solved by: Madhuri Choutkur Nov 22, 2016
Answered

How to set the minimum iOS version in Kony Visualizer Enterprise 7

Question asked by Martin Krischik on Nov 04, 2016 13:07 EDT

My build fails with the following error: ————— [exec-shell] clang: warning: libstdc++ is deprecated; move to libc++ [exec-shell] ld: embedded dylibs//frameworks are only supported on iOS 8.0 and later (@rpath//ScanbotSDK.framework//ScanbotSDK) for architecture i386 [exec-shell] clang: error: linker command failed with exit code 1 (use -v to see invocation) [exec-shell] [exec-shell] -- BUILD FAILED -- [exec-shell] [exec-shell] [exec-shell] The following build commands...

View all replies

Hi Krischik, In the IDE we do not have the provision to set the iPhone Deployment Target. Pointed line will execute...

View full answer

Answered by: Shaik Mohammad Jabiulla Nov 05, 2016
Solved

When migration a project to Kony Visualizer Enterprise 7 access to custom libraries is lost.

Problem posted by Martin Krischik on Nov 04, 2016 11:31 EDT

After migrating to Kony Visualizer Enterprise 7 the custom libraries for Android are not build into the project any longer. The build of course fails.

View all replies

Well, that was a simple one. Just had to copy the jar files to the appropiate places again.

View full answer

Solved by: Martin Krischik Nov 04, 2016

Pages