All MADP Posts

Android OREO

Faizan Khalidi - Sep 13, 2017 - Blog

Google recently announced the General Availability (GA) of its most recent Operating System, Android Oreo (O).

Here is a brief update on the compatibility of your applications with Android Oreo.

All the existing applications built using the latest versions of the supported Kony Visualizer releases for Tablet and Phone, will be compatible with Android Oreo. To ensure compatibility of your applications with Android Oreo, upgrade to the latest minor version on your specific Kony Visualizer release and this will ensure compatibility for your Apps.

For current Kony customers to receive these updates you must have a version of the Kony platform that is currently in mainstream support (i.e. released within the past two years). This means that customers should be on version 6.5 or higher. Customers on older versions of the Kony platform should contact Customer Success to discuss options for upgrading and extended product support options.

Apart from the compatibility support, we know that our customers are also very interested in taking advantage of new developer APIs in this new OS release. We are planning to provide 100% coverage for the new Android Oreo APIs in an upcoming release of the Kony platform.

As always, you can be assured that with Kony, your mobile app is taken care of! Under our unique SLA, we contractually commit to providing you app compatibility support for updated OS releases within 30 business days.


If you have any questions about your applications, please don’t hesitate to reach out to your Customer Success team representatives or Kony Support.